LegacyCollector

Home | Legacy Firefox Extensions | Content Policy | Contact

googlebar

Author(s):



A version with seamonkey 2.0 and firefox 3.6.x support has been added as version 0.9.20.03 this is otherwise identical to the previous versions except for some very minor bug fixes.

A firefox 3 compatible version (0.9.15.13) is now available- enjoy! As always, this provides easy access to many specialized features of Google. Feedback is always welcome, here or at our forums. An update to version 0.9.15.13, now 0.9.15.14 allows Firefox 1.5x and 2.x users to install from here. Otherwise, identical to 0.9.15.13.

Download files:

googlebar-0.9.00.16.xpi
googlebar-0.9.00.28.xpi
googlebar-0.9.00.29.xpi
googlebar-0.9.00.30.xpi
googlebar-0.9.05.06.xpi
googlebar-0.9.12.01.xpi
googlebar-0.9.15.07.xpi
googlebar-0.9.15.10.xpi
googlebar-0.9.15.11.xpi
googlebar-0.9.15.13.xpi
googlebar-0.9.15.14.xpi
googlebar-0.9.20.03.xpi
googlebar-0.9.20.05.1-signed.1-signed.xpi




This page is part of the LegacyCollector website.
Disclaimer: All material on this site is property of their respective owners and available under
open licenses to the best of our knowledge. If you are an author and would like anything removed,
then please write an e-mail to legacy [at] collector dot org.