TTS for Linux

Author(s):



References:
**********
+ kttsd: http://docs.kde.org/development/en/kdeaccessibility/kttsd/introduction.html
+ Dcop: http://en.wikipedia.org/wiki/Dcop


YouTube:
Configuring Talkers ==> http://www.youtube.com/watch?v=if0lWJa6jOg
Extension use ==> http://www.youtube.com/watch?v=z29nzVSJ1E8


##################################################################
If the executing addon generates an error message, make the file "speech.sh"
executable. In a shell (Terminal) set the file "speech.sh" to execute by typing:
chmod +x `find ~/.mozilla/ -name speech.sh -print`
##################################################################


+++++++++++++++++++++++++++++++Ubuntu/Kubuntu+++++++++++++++++++++++++++++++++++++++++++
1. Add these lines to your "/etc/apt/sources.list" file (Ubuntu KDE 3.5 Repository):

For Maverick [STABLE] (4 lines):
deb http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity/ubuntu maverick main
deb-src http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity/ubuntu maverick main
deb http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-builddeps/ubuntu maverick main
deb-src http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-builddeps/ubuntu maverick main

For Lucid [OLDSTABLE] (2 lines):
deb http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu lucid main

For Karmic [LEGACY] (2 lines):
deb http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu karmic main
deb-src http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu karmic main

For Jaunty [LEGACY] (4 lines):
deb http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu jaunty main
deb http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu intrepid main
deb-src http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu intrepid main

For Intrepid [LEGACY] (2 lines):
deb http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu intrepid main
deb-src http://ppa.launchpad.net/kde3-maintainers/ppa/ubuntu intrepid main

2. Add the GPG signing key:
sudo apt-key adv --keyserver keyserver.quickbuild.pearsoncomputing.net --recv-keys 2B8638D0


3. After adding of a repository, it needs to be refreshed:
sudo apt-get update

4. Install kttsd fo KDE 3.5:
sudo apt-get install kttsd-kde3

5. DCOP
sudo ln -s /opt/kde3/bin/dcop /usr/bin/dcop

7. Install "TTS for Linux 0.1.6" extension:
https://addons.mozilla.org/en-US/firefox/addon/tts-for-linux/

8. make the file "speech.sh" executable:
chmod +x `find ~/.mozilla/ -name speech.sh -print`

9. start kttsd and kttsmgr:
/opt/kde3/bin/kttsd
/opt/kde3/bin/kttsmgr
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++




+++++++++++++++++++++++++++++OpenSuSE+++++++++++++++++++++++++++++++++++++++++++++++
The following software packages must be installed with YAST (OpenSuSE 11.x),
if you have changed on KDE4 as a Defaultdesktop

- KDE3 Basissystem,
- kdelibs3
- kdeaccessibility3

The "kttsmgr" for KDE4 is still faulty.

OpenSuSE 11.x
*******************
1. Add "KDE3" repository:
openSUSE_11.1:
zypper ar -t YUM http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_11.1 KDE3
openSUSE_11.2:
zypper ar -t YUM http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_11.2 KDE3
openSUSE_11.3:
zypper ar -t YUM http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_11.3 KDE3
openSUSE_11.4:
zypper ar -t YUM http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_11.4 KDE3

2. After adding of a repository, it needs to be refreshed:
zypper refresh

3. Install "kdebase3" and "kdeaccessibility3" packages:
zypper in kdebase3 kdeaccessibility3

4. DCOP
sudo ln -s /opt/kde3/bin/dcop /usr/bin/dcop
sudo ln -s /opt/kde3/bin/kttsmgr /usr/bin/kttsmgr
sudo ln -s /opt/kde3/bin/kttsd /usr/bin/kttsd

5. Install "TTS for Linux 0.1.6" extension:
https://addons.mozilla.org/en-US/firefox/addon/tts-for-linux/

6. make the file "speech.sh" executable:
chmod +x `find ~/.mozilla/ -name speech.sh -print`

7. Starting KTTSMgr:
/opt/kde3/bin/kttsmgr or kttsmgr

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Supported languages:
- German
- UK English
- U.S. English
- French
- Spanish
- Italian
- Russian
- Chinese
- Dutch
- Greek
- Japanese
- Korean
- Portuguese
- Swedish

If I haven't included the language you're looking for, check back soon.

Download files:

tts-for-linux-0.1.6-linux.xpi


This page is part of the LegacyCollector website.
Disclaimer: All material on this site is property of their respective owners and available under
open licenses to the best of our knowledge. If you are an author and would like anything removed,
then please write an e-mail to legacy [at] collector dot org.